Installation

This part of the documentation covers the installation of intercepts.

Install with pip

Intercepts requires Python 3.5+. There are currently no additional dependencies. To install intercepts, just run this command in your favorite terminal:

$ pip install requests

Or, to install the latest version from the github source, run the following command:

$ pip install -U git+https://github.com/dlshriver/intercepts.git@master

Get the Source

The intercepts module is under active development, and the code is available on Github.

You can either clone the public repository:

$ git clone git://github.com/dlshriver/intercepts.git

Download the tarball:

$ curl -OL https://github.com/dlshriver/intercepts/tarball/master

Or, download the zip archive:

$ curl -OL https://github.com/dlshriver/intercepts/archive/master.zip